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1. OVERVIEW 

This Overview describes: 

 About the XML Client Interface for DAZzle and Endicia for Mac 

 Standards 

 Platform Differences 

 Actions Supported 

 Pass XML Data into DAZzle [Windows Only] 

 Pass XML Data into Endicia for Mac [Mac Only] 

 DAZzle Root XML Tag Options 

 Current Changes 

 

About the XML Client Interface for DAZzle and Endicia for Mac 

 

Endicia supports a variety of XML-based interfaces that can greatly enhance the communication between 

DAZzle or Endicia for Mac and other applications or systems. The Endicia XML Client Interface allows 

other applications to supply or retrieve information from Endicia, our postage printing service, using 

industry standard protocol. Also, a limited number of automation capabilities using the XML interface 

can streamline the interface process. 

 

Note: This document has been updated to support both DAZzle and Endicia for Mac. Unless 

otherwise indicated, all methods are supported on both platforms. 

 

Refer to the Current Changes section of this document for a list of changes.  

 

Although there are already many powerful features, the XML interface is evolving to increase its 

functionality and breadth of information supported. Due to XML’s flexibility, this should not cause 

backwards compatibility issues with early adopters of the interface, but there is no guarantee that new 

versions of DAZzle and Endicia for Mac may not require some modifications to existing systems. 

 

If you are using the XML interface to Endicia as part of a product that will be distributed to other 

customers, please provide us with information about your interface. As part of our efforts to provide 

quality customer support for Endicia and any integrated or related products, please provide the following 

information: 

 

 Name of the product and company supporting the Endicia XML Client Interface. 

 Contact information (e-mail address and phone number) that our customers can use. 

 Technical contact information (e-mail address and phone number) for Endicia technicians or 

developers. 

 Types of interface support, for example, command line, directory monitoring, or Clipboard, and 

so on. 

 Platforms tested on (Windows, Mac). 

 Any instructions you give your customers or screenshots of the interface. 

 

Please send this information by e-mail to partners@endicia.com.  

 



 

CONFIDENTIAL  Endicia, A Newell Rubbermaid Company  Page 5 

Standards 

 

DAZzle and Endicia for Mac support various different XML interfaces for different functions, and thus 

there are some differences in the syntax for each case. When similar information is shared between 

different functions, the XML is consistently named and used, but not all interfaces support the same 

feature set. Each of the interfaces described in this document details the supported tags and proper usage. 

 

Platform Differences 

 

DAZzle is the Microsoft Windows®-based client application for the Endicia Postage Printing service, and 

Endicia for Mac is the Apple® Mac OS X℠-based client application. Although they differ in their user 

interface, both have the same or similar postage-printing functionality and support most of the same XML 

commands. Due to platform and development differences, there are some differences. In this document, 

you can assume the XML will work on either platform unless otherwise noted. Each platform has a 

slightly different feature set. For example: 

 

 Endicia for Mac does not support Layout files, so Endicia for Mac ignores those sections of the 

Endicia XML Client specification.  

 DAZzle does not support Return Address Nicknames, so DAZzle ignores those XML tags.  

 

Platform-specific features are identified by either: 

 

 [Windows Only]—for DAZzle  

 [Mac Only]—for Endicia for Mac. 

 

Actions Supported 

 

XML-formatted data can be used in a number of different ways within the client applications: 

 

 Printing: DAZzle can print one or many addresses from an XML file. For more information, see 

the Printing section. 

 Verifying Addresses: DAZzle can verify (and update) address information in an XML file. For 

more information, see the Address Verification section. [Windows Only] 

 Importing into the Address Book: XML data can be loaded into the current DAZzle address book 

through XML. For more information, see the Address Book section. [Windows Only] 

 Exporting Data from the Postage Log: Data from the DAZzle Postage Log can be copied to an 

XML-formatted file for transfer to other applications. For more information, see Postage Log 

section. 

 

Pass XML Data into DAZzle [Windows Only]  

 

The first three methods listed below use a standard Windows text file that contains XML-formatted data 

(as specified in the following sections). These XML-based files must use the extension ―XML‖ for proper 

recognition and usage, for example packagedata.xml. 

 



 

CONFIDENTIAL  Endicia, A Newell Rubbermaid Company  Page 6 

Printing, verifying, and importing addresses into the Address Book require XML files as inputs to 

DAZzle in order to work. Exporting data from the Postage Log creates an XML file as output to the menu 

item selected in DAZzle.  

 

Interactively Using the DAZzle Menu 

 

Through menus in DAZzle, you can interactively invoke each of the following actions using XML data: 

 

 Print an XML-Formatted File 

 Verify Addresses in an XML-formatted File  

 Import Addresses into the Address Book 

 Export Data from the Postage Log 

 
Print an XML-Formatted File 

 

The following step describes how to begin the process of printing an XML-formatted file. 

 

Step 
 

 From the Design tab in DAZzle, select File > Print from…External File.  

For more information, see the Printing section. 

 
Verify Addresses in an XML-formatted File 

 

The following step describes how to verify addresses in an XML-formatted file. 

 

Step 
 

 From the Design tab in DAZzle, select Layout > Dial-A-ZIP from…External File.  

For more information, see the Address Verification section. 

 
Import Addresses into the Address Book 

 

The following step describes how to import addresses into the Address Book. 

 

Step 
 

 From the Address Book tab in DAZzle, select File > Import, and then select an XML file.  

For more information, see the Address Book section. 

 
Export Postage Log Data  

 

The following steps describe how to export Postage Log data. 

 

Steps 
 

1. From the Postage Log tab, select File > Export.  

2. Enter a starting date and an ending date.  

3. Click the Export button.  
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4. In the Select Export File window: 

a. Enter the name of an XML file to create. 

b. In the Save as type field, select Text, XML Format.  

5. Click Save. 

For more information, see the Postage Log section. 

 

Using the Command Line 

 

DAZzle operations can be automated by launching DAZzle with an XML file in the command line 

interface. The specified XML file should include the optional ―DAZzle‖ attributes to signal DAZzle 

which method to invoke (and any desired options for that method).  

 

For example, the following command causes DAZzle to: 

 Automatically load the file ―c:\lists\listfile.xml‖ when DAZzle is launched. 

 Follow any specified commands within the XML file. 

 
dazzle.exe c:\lists\listfile.xml 

 

If no automation command is within the XML file, DAZzle takes no action.  

 

Refer to the method details for the attributes appropriate to that method. Also note that no other command 

line option can be used when specifying an XML file (the XML format provides for invoking other 

options). 

 

Using Directory Monitoring 

 

DAZzle monitors the directory ―<dazzle>\xml‖ where <dazzle> is the directory containing the DAZzle 

executable for any XML files. When an XML file is found in this directory, it is automatically opened and 

printed according to all applicable tag commands. This feature can be used to automate DAZzle from 

other programs that produce XML output but have trouble launching DAZzle. Every 30 seconds DAZzle 

automatically checks the specified directory for any XML files. DAZzle prints the first XML file it finds, 

performing the print as if a user had selected it. When DAZzle is finished printing, the file is renamed 

with a ―.BAK‖ extension so that the file is not processed repeatedly.  

 

When using the directory monitoring option, the XML file must include the OutputFile option of the 

DAZzle tag, and that filename must use a different directory than the source directory or it will repeatedly 

process the file. For automation option information, see the DAZzle Printing XML Syntax section. 

 

Using the Clipboard 

 

The Clipboard can be used to transfer data to DAZzle for both the printing and address verification 

actions. The data should be formatted exactly the same as if these actions were performed using a file.  

If any DAZzle tag options are specified in the XML data, for example Start="PRINTING" or 

Prompt=―NO‖, DAZzle will respond accordingly with the exception of the AutoClose option. 

The following topics summarize the methods of retrieving data from the Clipboard: 

 

 Manually Retrieve Clipboard Data 
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 Automatically Retrieve Clipboard Data 

 
Manually Retrieve Clipboard Data 

 

The following step describes how to examine the Clipboard for XML-formatted data (one or more 

addresses may be in the XML data). 

 

Step 
 

 From the Design tab in DAZzle, select Edit > Paste Address.  

The following step describes how to obtain address verification of the XML data. 

 

Step 
 

 From the Design tab, select Layout > Dial-A-ZIP from…Clipboard. 

 
Automatically Retrieve Clipboard Data 

 

The following steps describe how to have DAZzle constantly monitor the Clipboard for data and 

immediately act upon any properly formatted XML data found. 

 

Steps 
 

1. From either the Design tab or the Address Book tab in DAZzle, select File > Preferences. 

2. On the Clipboard tab, select the Monitor Clipboard for Addresses option  

 

Pass XML Data into Endicia for Mac [Mac Only] 

 

Printing and Mailing-log exports use a text file that contains XML-formatted data, as specified in the 

following topics: 

 

 Print an XML-Formatted File 

 Export Data from the Mailing Log 

 

These XML-based files must use the extension ―XML‖ for proper recognition and usage, for example 

packagedata.xml. Endicia for Mac also supports passing the same XML tags for printing as a set of 

named pair through a custom URL type.  

 

Print from an XML-Formatted File 

 

The following step describes how to begin the process of printing from an XML-formatted file. 

 

Step 
 

 Do one or the other: 

o Select File > Print from External XML File.  

o Drag XML files on to the Endicia for Mac icon in the Dock. 

Endicia for Mac processes all the shipments contained in the file. 
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Export Data from the Mailing Log 

 

The following steps describe how to export data from the Mailing Log. 

 

Steps 
 

1. Make the Mailing Log visible by either: 

 Clicking the Mailing Log icon in the main window, or  

 Selecting Mailing Log > Mailing Log.  

2. Select Mailing Log > Export.  

3. In the Export window, select the Export option, and click OK.  

4. After entering the data range for the export data: 

a. Enter the name of an XML file to create. 

b. Select XML Format as the Save as type option.  

For more information, see the Postage Log section. 

 

Using the Command Line 

 

You can automate printing operations by using the EndiciaTool command-line application.  

 
./endiciatool -f /Users/username/sample-print.xml 

 

The Endicia command-line tool is in the Endicia for Mac Extras folder of the original Endicia for Mac 

download disk image. 

 
Using the Custom URL Type 

 

One way to integrate Endicia for Mac into an existing Web-based workflow is through the endicia:// URL 

type. Construct a URL that begins with endicia:// and use any of the tags found in the following 

XML specifications. The XML tags are not nested when placed in the URL and are included as named 

pairs, such as: 

 
endicia://newShipment2/?ToAddress=Pat%20Castaldo%0A312%20Columbia%20Str

eet%20NW%20%20Suite%203%0A Olympia%20WA%2098501%0Ausa; 

ReferenceID=12345;ToEMail=mac%40endicia.com;Value=25.98;ToPhone=;MailCl

ass=PRIORITY 

 

The endicia:// URLs can then be embedded in Web pages or called from other applications.  

 

The following commands are for the base command in the URL: 

 

 newShipment2/? (as illustrated in the preceding example) completes all of the necessary 

fields and prepares the label or envelope for printing, but does not actually print it. This allows 

the user to set other options interactively. 

 print/? sets up the label and sends it to the printer without allowing any options to be set 

interactively.  
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Current Changes 

This section describes current changes to the DAZzle XML interface. For information about changes to 

previous releases, see the Change History. 

Version 11.0 

This document includes the following updates: 

 Added the following value to the MailClass element of the XML Printing Elements table: 

o CRITICALMAIL 

 Added the following values to the PackageType element of the XML Printing Elements table: 

o FLATRATELEGALENVELOPE 

o FLATRATEGIFTCARDENVELOPE 

o FLATRATEWINDOWENVELOPE 

o FLATRATECARDBOARDENVELOPE 

o SMALLFLATRATEENVELOPE 

o REGIONALRATEBOXA 

o REGIONALRATEBOXB 

 Changed the description of the following PackageType element of the XML Printing Elements 

table: 

o FLATRATEPADDEDENVELOPE 

 Added the following elements to the Services element of the XML Printing Elements table: 

o HoldForPickup 

o HFPFacilityID 

o HFPFacilityName 

o HFPFacilityAddress 

o HFPFacilityCity 

o HFPFacilityState 

o HFPFacilityZip5 

o HFPFacilityZip4 

Version 10.3 

This document includes the following update: 

 Added code -12 Invalid feature for account to Appendix B. Values for Status Tags. 

Version 10.1 

With the DAZzle 10.1 release, this document includes the following updates: 

 Added support for additional numbered element tags 6-30 for CustomsQuantity. 

CustomsDescription, CustomsWeight, CustomsValue, and CustomsCountry. 

 Added new CustomsHTS tag to XML Printing Elements table. 

 May 25, 2010: Fixed typographical error. Was:  
<ServicesCertifiedMail="OFF" DeliveryConfirmation="ON" 

></Services>  

Corrected to: 
<Services CertifiedMail="OFF" DeliveryConfirmation="ON" 

></Services> 

Version 10.0 

With the DAZzle 10.0 release, this document includes the following updates: 

 Added the new Flat Rate Padded Envelope package type. 

 Added a new Parcel Select mail class. 
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 Added a new value for status tag: -5, Unsupported domestic mail options (Windows only). See 

Appendix B. 

Version 9.3.01  

With the DAZzle 9.3.01 release, this document includes a new chapter, Vista and Windows 7 Compatible 

Installation and Updates, which describes the registry entries that make DAZzle data compatible with 

Microsoft Vista and Windows 7. 
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2. DAZZLE ROOT XML TAG OPTIONS 

 

You can automate the processing of XML files and reduce the number of prompts to the user who is using 

the DAZzle XML root tag options. For Windows and Mac, the word ―DAZzle‖ must always be the root 

element (the ―header‖ tag) in the file and can use the options described below. 

 

Note [Windows Only]: All DAZzle element attributes are ignored when invoking printing from 

the menu (that is, by selecting File > Print from…External File) because all options are set 

interactively.  

 

The following topics describe the root-level tag options: 

 

 Automatically Invoke DAZzle Options–Start 

 Change Layouts–Layout[Windows Only] 

 Turn Off Alert Dialogs and Prompts–Prompt 

 Abort Process When Prompts Are Disabled–AbortOnError 

 Specify the Output File Name–OutputFile 

 Automatically Close DAZzle when Done–AutoClose 

 Print Test Labels–Test 

 Skip Addresses That Do Not Verify–SkipUnverified 

 Automatically Print Customs Forms–AutoPrintCustomsForms 

Automatically Invoke DAZzle Options—Start 

 

DAZzle actions can be automatically invoked using the Start attribute of the DAZzle tag.  

 Set Start="PRINTING" to start the printing of the XML data. 

 Set Start="DAZ" to start the address verification process on the XML data. This option ONLY 

applies when using the Command Line launch method. For more information, see Using the 

Command Line [Windows Only]. 

 

Important! The following options do not apply to the address verification process. 

Change Layouts—Layout [Windows Only] 

 

Setting the Layout value to the fully qualified path name of a DAZzle layout file causes DAZzle to 

change to that layout prior to printing. This change only occurs one time per file (for example, you cannot 

change layouts in the middle of printing).  

 

Note: The Change Layouts–Layout option does not apply to the address verification process. 

Turn Off Alert Dialogs and Prompts—Prompt 

Setting the Prompt value to ―NO‖ causes the client application to suppress all option and information 

windows (for example, the ―Don’t remind me again‖ dialog windows) so that printing is fully automated. 

Error messages may continue to appear.  

 

Note: The Turn Off Alert Dialogs and Prompts–Prompt option does not apply to the address 

verification process. 
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For information about error handling, see the AbortOnError option, which follows. The default value for 

this attribute is ―YES‖.  

 

Important! If the Prompt=―YES‖ option is selected, the user cannot override any value specified 

in the XML file. Thus, do NOT include data values for items that the user should enter or select. 

 

Abort Process When Prompts Are Disabled—AbortOnError [Windows Only] 

If the Prompt value is ―YES‖ or AbortOnError value is ―NO‖, DAZzle prompts the user to respond 

should an error occur that causes either the Confirmation or Express Mail tracking number process or 

Endicia Postage process to fail. The user must then choose to continue despite the error or may abort the 

list printing. If AbortOnError is set to ―YES‖, all error messages are suppressed and DAZzle 

automatically aborts the list process if an error occurs. The default value for this attribute is ―NO‖. 

 

Note: The Abort Process When Prompts Are Disabled–AbortOnError option does not apply to 

the address verification process. 

 

Specify the Output File Name—OutputFile 

When the Prompt value is ―YES‖ (which is the default value), DAZzle prompts the user for the output file 

name. You can bypass the prompt and specify the output file name by using the OutputFile value. (For 

more information, see Output Information in the Printing section.) If no output file name is specified and 

the Prompt value is set to ―NO‖, the output file is automatically named ―filename-output.xml‖. Endicia 

for Mac will not prompt to name the output file, regardless of the value of this setting. 

Note: The Specify the Output File Name–OutputFile option does not apply to the address verification 

process. 

Automatically Close DAZzle When Done—AutoClose [Windows Only] 

Setting the AutoClose value to ―YES‖ causes DAZzle to automatically close when the printing of the 

addresses in the file is complete. The default value for this attribute is ―NO‖.  

 

Note: The Specify the Output File Name–OutputFile option does not apply: 

 To the address verification process. 

 When printing from the Clipboard. 

Print Test Labels—Test 

Setting the Test value to ―YES‖ causes DAZzle or Endicia for Mac to print sample indicia on each piece 

in the mailing and NOT use actual postage. This attribute can be useful to make test runs to make sure the 

printing and data are all correct before using actual postage. If this attribute is not specified, the real 

postage will be used. If you have also selected the Prompt=―YES‖ option, then this feature has no effect 

because the user can select Test Print or Print. 

 

Note: The Print Test Labels–Test option does not apply to the address verification process. 
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Skip Addresses That Do Not Verify—SkipUnverified  

Normally, DAZzle prints every address on a list, even if the address cannot be verified. When an address 

is not verified, no postage is printed with the unverified address. To skip the unverified addresses during 

printing, set the SkipUnverified value to ―YES‖. Endicia for Mac will always skip unverified addresses. 

Note: The Skip Addresses That Do Not Verify–SkipUnverified option does not apply to the address 

verification process.  

 

Note: Endicia for Mac will not print addresses that cannot be verified. 

Automatically Print Customs Forms—AutoPrintCustomsForms [Windows Only] 

When printing from XML, DAZzle normally does not automatically print customs forms because it 

requires printing to a second printer and requires prompting the user, which disrupts the automated 

process.  

 

Note: The Automatic Printing of Customs Forms–AutoPrintCustomsForms option does not apply 

to the address verification process. 

 

Note: Endicia for Mac allows you to set a separate printer for customs forms and will 

automatically print the customs forms to that printer. The following section does not apply. 

 

Use of this option (setting the value to ―YES‖) causes DAZzle to automatically print the requested 

customs form to the default Windows printer. (That is, there is no prompt to select the printer.) To make 

the best use of this option when using two printers, the label printer should be set in the DAZzle layout, 

and the default Windows printer should be set to a plain paper printer for the customs forms. Also 

remember that the customs form information only prints for items that request the customs form through 

XML data and have all the customs information properly supplied. 

 

If this item is omitted or set to ―NO‖, DAZzle creates and records the customs form information, but will 

NOT print or prompt you to print the customs form during the printing process. Instead, the customs 

forms can be printed from the Postage Log with the Print Record option. 
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3. PRINTING 

Printing of a single item or a list of items can be accomplished with appropriately formatted XML data 

(using either a file or the Clipboard).  

 

Topics in this section include: 

 

 DAZzle Printing XML Syntax 

Endicia XML Client Printing Syntax  

The Endicia Client XML printing tags are described in detail in the XML Printing Elements table.  

 

The following important notes apply to all elements in the following table: 

 

 Omitting any value causes the client application to use the current value for that element (or in 

the case of a list, the value for the previous item). This is especially important to consider for 

options that impact the rate paid (for example, insurance, Delivery Confirmation). If you turn ON 

an item for a single piece you MUST turn it off on the next item or it will stay on! 

 Italic items are optional.  

 Bold items are updated (or added if missing) when creating the output file or data. 

 Gray Elements indicate the difference between the Windows (PC) and Mac implementations. 

XML Printing Elements 

Element Type Size or Values Description 

DAZzle Root - The root node for the XML request. 
 Layout 

[Windows Only] 
attribute Filename The fully qualified pathname of a DAZzle 

layout file. The attribute does NOT apply 
when started by selecting File > Print 
From External File from the Design tab. 

Prompt attribute YES or NO A value of NO causes DAZzle to suppress 
all printing windows and information 
boxes. This option does NOT apply to 
Start=”DAZ”. 

AbortOnError 
[Windows Only] 

attribute YES or NO A value of YES causes DAZzle to stop the 
list processing when a Delivery 
Confirmation or postage error is 
encountered AND the Prompt attribute is 
“NO”. The default value is NO. 

Test attribute YES or NO A value of YES causes DAZzle to use 
sample postage for testing purposes. Any 
other value (or omission of this attribute) 
will use real postage. This option does 
NOT apply when Prompt=”YES” (user 
clicks the Test Print button from the Print 
dialog box instead). 

Start 
[Windows Only] 

attribute PRINTING 
 
DAZ 

A value of PRINTING causes DAZzle to 
automatically start printing.  
A value of DAZ starts the address 
verification process. 
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Element Type Size or Values Description 
OutputFile attribute Filename A value of Filename uses the fully 

qualified path name of a file for the 
output results of a printing. 

SkipUnverified 
[Windows Only] 

attribute YES or NO A value of YES causes DAZzle to not print 
addresses that cannot be verified. If set to 
NO (the default value) all addresses are 
printed, but if the address does cannot be 
verified, no postage will be printed with 
that address. 

AutoClose 
[Windows Only] 

attribute YES or NO A value of YES causes DAZzle to 
automatically close at the end of printing. 
This attributed does not apply to 
Start=”DAZ”. The default value is NO.  

AutoPrintCustomsForms 
[Windows Only] 

Attribute YES or NO A value of YES causes DAZzle to print any 
requested customs form to the default 
Windows printer. 
Endicia for Mac will always print a 
customs form, if possible. 

Package Node  Package information. 

 ID Numeric 
attribute 

1-n Specify the numeric identifier for each 
package in the request. There may be 
multiple package (indicium) requests. 
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Element Type Size or Values Description 
MailClass Text NONE 

 
FIRST 
 
PRIORITY 
 
PARCELPOST 
 
MEDIAMAIL 
 
LIBRARYMAIL 
 
BOUNDPRINTEDMATTER 
 
EXPRESS 
 
PRESORTEDFIRST 
 
PRESORTEDSTANDARD 
 
INTLFIRST 
 
INTLEXPRESS 
 
INTLPRIORITY 
 
INTLGXG 
 
INTLGXGNODOC 
 
 
PARCELSELECT 
 
 
CRITICALMAIL 

Do not print postage 
 
First Class Mail® 
 
Priority Mail® 
 
Parcel Post® 
 
Media Mail® 
 
Library Mail 
 
Bound Printed Matter  
 
Express Mail® 
 
Presorted, First-Class® 
 
Presorted, Standard Class 
 
First-Class Mail International® 
 
Express Mail International® 
 
Priority Mail International® 
 
Global Express® Guaranteed 
 
Global Express Guaranteed Non- 
Documents 
 
Parcel Select®. Delivery Confirmation or 
Signature Confirmation is required. 
 
Critical Mail—Only available to qualified 
Commercial Plus customers. PackageType 
has to be ENVELOPE or FLAT. 

DateAdvance numeric 0-30 Specify the number of days to advance 
date the indicium. If you are using Delivery 
Confirmation, the maximum value is 7 
days. 
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  PackageType Text POSTCARD 
 
ENVELOPE 
 
FLAT 
 
RECTPARCEL 
 
NONRECTPARCEL 
 
FLATRATEENVELOPE 
 
FLATRATEBOX 
 
FLATRATELARGEBOX  
 
 
FLATRATESMALLBOX 
 
 
FLATRATEPADDEDENVELO
PE 
 
FLATRATELEGALENVELOPE 
 
 
REGIONALRATEBOXA 
 
 
REGIONALRATEBOXB 
 
 
FLATRATEGIFTCARDNVELO
PE 
 
FLATRATEWINDOWENVEL
OPE 
 
FLATRATECARDBOARDENV
ELOPE 
 
SMALLFLATRATEENVELOP
E 
 

Postcard  
 
First-Class Mail Letter 
 
First-Class Mail Large Envelope 
 
Rectangular Parcel–the standard parcel 
 
Non-rectangular parcel–impacts rate for 
Priority Mail 
Flat Rate Envelope–Priority and Express 
Mail 
Flat Rate Box–Priority Mail 
 
Large Flat Rate Box–Priority Mail 
(Domestic and International) 
 
Small Flat Rate Box–Priority Mail 
(Domestic and International) 
 
Flat Rate Padded Envelope–Priority Mail  
 
 
Flat Rate Legal Envelope–Priority Mail and 
Express Mail (Domestic only) 
 
Regional Rate Box A–Priority Mail 
(Domestic only) 
 
Regional Rate Box B–Priority Mail 
(Domestic only) 
 
Flat Rate Giftcard Envelope–Priority Mail 
and Express Mail (Domestic only) 
 
Flat Rate Window Envelope–Priority Mail 
and Express Mail (Domestic only) 
 
Flat Rate Cardboard Envelope–Priority 
Mail and Express Mail (Domestic only) 
 
Small Flat Rate Envelope–Priority Mail and 
Express Mail (Domestic only) 
 

ReplyPostage Text TRUE 
FALSE 

TRUE indicates that the item should print 
with reply postage, which means the 
Return and Destination addresses will be 
swapped when printing. 

WeightOz Numeric 0.0 to 1130.0 ounces Set the weight of the package in ounces–
to ONE decimal place. 
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Width Numeric 0.00 to 130.00 inches Set the width (or height) of envelope, flat, 
or package. Optional, but should be 
supplied with Priority Mail items and is 
optional on all others. 
This value is required for qualified 
customers to access the Commercial Plus 
Cubic Pricing.  If left blank, DAZzle will 
return weigh-base pricing. 

Length Numeric 0.00 to 130.00 inches Set the length of envelope, flat or 
package. Optional, but should be supplied 
with Priority Mail items and is optional on 
all others. 
This value is required for qualified 
customers to access the Commercial Plus 
Cubic Pricing.  If left blank, DAZzle will 
return weigh-base pricing. 

Depth Numeric 0.00 to 130.00 inches Set the depth (or thickness) of envelope, 
flat, or package. Optional, but should be 
supplied with Priority Mail items and is 
optional on all others. 
This value is required for qualified 
customers to access the Commercial Plus 
Cubic Pricing.  If left blank, DAZzle will 
return weigh-base pricing. 

BalloonRate Text TRUE 
FALSE 

TRUE means to use the “balloon rate” for 
Priority Mail (the 20 lb rate).  

NonMachinable Text TRUE 
FALSE 

TRUE means use non-machinable rates. 
Applies to First-Class, Parcel Post, and 
First-Class Mail International.  

OversizeRate Text TRUE 
FALSE 

TRUE means use oversized rate for Parcel 
Post–NonMachinable MUST also be TRUE. 

Stealth Text TRUE 
FALSE 

Use TRUE to turn on the use of “stealth” or 
hidden postage. Use FALSE to turn off 
stealth. NOTE: Stealth can only be use on 
items with either confirmation or tracking. 

SignatureWaiver Text TRUE 
FALSE 

For Express Mail or Signature 
Confirmation, indicates if the signature 
requirement can be waived. Use TRUE to 
allow waiver of signature. 

ExpressMailPremium 
Service 

Text TRUE 
 
 
FALSE 

Enable Premium Service (Sunday/Holiday 
Delivery) for Express Mail–ONLY applies 
when Mail Class is Express Mail 
Turn off Premium Service. 

NoWeekendDelivery Text TRUE 
FALSE 

For Express Mail, use TRUE to request NO 
delivery on a weekend. 

NoHolidayDelivery Text TRUE 
FALSE 

For Express Mail, use TRUE to request NO 
delivery on a holiday. 

ReturnToSender Text TRUE 
FALSE 

For Global Express Mail, use TRUE to 
indicate item should be returned to sender 
if undeliverable. Currently this MUST be 
TRUE. 
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Services Node  Special Services requested for the 
package. 

 RegisteredMail Attribute ON 
OFF 

Registered Mail requested 
Registered Mail not requested 

InsuredMail Attribute ON 
 
 
 
OFF 
 
ENDICIA 
 
 
 
UPIC 

USPS Insurance requested 
Note: USPS Insurance is not allowed with 
Stealth=TRUE 
 
No insurance requested 
 
Endicia Parcel Insurance requested 
Note: The maximum insurable value for 
Endicia Parcel Insurance is $10,000. 
 
UPIC insurance requested 
 
Note: Endicia for Mac supports only 
Endicia Parcel Insurance. 

CertifiedMail Attribute ON 
 
OFF 

Certified Mail requested 
 
Certified Mail not requested 

RestrictedDelivery Attribute ON 
 
OFF 

Restricted Delivery requested 
 
Restricted Delivery not requested 

CertificateOfMailing Attribute ON 
 
OFF 

Certificate Of Mailing requested 
 
Certificate Of Mailing not requested 

ReturnReceipt Attribute ON 
 
OFF 

Return Receipt requested 
 
Return Receipt not requested 

DeliveryConfirmation  Attribute ON 
 
OFF 

Delivery Confirmation requested 
 
Delivery Confirmation not requested 

SignatureConfirmatio
n  

Attribute ON 
 
OFF 

Signature Confirmation requested 
 
Signature Confirmation not requested 

COD Attribute ON 
 
OFF 

COD requested 
 
COD not requested 

HoldForPickup Text TRUE 
FALSE 

For Express Mail, Priority Mail, First Class 
Mail, Parcel Select, use TRUE to indicate 
Hold For Pickup requested. 

HFPFacilityID Text 20 Facility ID of the Post Office that will hold 
the item for pickup. 

HFPFacilityName Text 150 Facility name of the Post Office that will 
hold the item for pickup. 

HFPFacilityAddress Text 150 Facility address of the Post Office that will 
hold the item for pickup. 

HFPFacilityCity Text 50 City of the Post Office that will hold the 
item for pickup. 
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HFPFacilityState Text 25 State of the Post Office that will hold the 
item for pickup. 

HFPFacilityZip5 Text 5 5 digit ZIP Code of the Post Office that will 
hold the item for pickup. 

HFPFacilityZip4 Text 4 +4 add-on ZIP Code of the Post Office that 
will hold the item for pickup. 

CostCenter Numeric 8 Optional cost-center code for accounting 
purposes 

Value Currency 99,999.99 Value of the item shipped. Used for 
insurance and other optional services (to 
the cent). Required if an optional service 
is used that requires this value. For items 
that use the international mail customs 
forms, this value must be the sum of the 
individual customs items.  

Description Text 50 Description of the item shipped. Used for 
authentication by recipient 

 

CustomsFormType Text NONE 
 
CN22 
 
CP72 

Optional: Type of customs form to create  
 
CN22 is the same as Form 2976. 
 
CP72 is the same as 2976A. 

CustomsQuantityN Numeric 8 Optional: “N” can be any integer from 1 
through 30. Quantity of the “Nth” item in 
customs declaration.  
For Windows only. 

CustomsDescriptionN Text 50 Optional: “N” can be any integer from 1 
through 30. Description of the “Nth” item 
in the customs declaration.  
For Windows only. 

CustomsWeightN Numeric 8 Optional: “N” can be any integer from 1 
through 30. Weight of the “Nth” item in 
customs declaration–in ounces. 

CustomsValueN Currency 99,999.99 Optional: “N” can be any integer from 1 
through 30. Value of the “Nth” item in the 
customs declaration.  
For Windows only. 

CustomsCountryN Text 25 Optional: “N” can be any integer from 1 
through 30. Country of Origin for the 
“Nth” item in the customs declaration. 
This MUST be a valid, USPS recognized 
country.  
For Windows only. 

CustomsHTSN Numeric 10 Optional: “N” can be any integer from 
1 through 30. Harmonized Tariff 
Schedule (HTS) ID for the “Nth” item in 
customs declaration.  
For Windows only. 
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ContentsType Text SAMPLE 
GIFT 
DOCUMENTS 
OTHER 
MERCHANDISE 
RETURNEDGOODS 

Optional: Type of contents for 
international customs forms. Must be one 
of these values. 

CustomsSigner Text 100 Name of person certifying that the 
customs information is correct. This name 
will be printed on the customs form in 
place of a signature IF CustomsCertify is 
TRUE. 

CustomsCertify Text TRUE 
FALSE 

TRUE means the customs information is 
certified to be correct and the 
CustomsSigner name should be printed.  

EndorsementLine Text 150 Address endorsement line, for example, 
AutoCR xx **. Always first addressline,if 
used. 

ReferenceID Text 25 A reference value for logs 

ToName Text 150 Destination Name 

ToTitle Text 150 Title (follows name line) 

ToCompany Text 150 Company name 

ToAddress1 Text 150 First address line  

ToAddress2 Text 150 Second address line  

ToAddress3 Text 150 Third address line  

ToAddress4 Text 150 Fourth address line  

ToAddress5 Text 150 Fifth address line  

ToAddress6 Text 150 Sixth address line  

ToCity Text 50 Destination City  

ToState Text 25 Destination State or Province  

ToPostalCode Text 15 Destination Postal-code. The format is 
either ZIP5 only or ZIP+4 for US addresses. 

ToZIP4 Text 5 +4 add-on for US addresses. 

ToCountry Text 50 Destination Country. This value should be 
left blank for USA addresses. 

ToDeliveryPoint Text 3 Delivery point digits for destination 
address 

ToCarrierRoute Text 5 Carrier route for destination address 

ToReturnCode Text 3 CASS returncode for address validation. 
Refer to the Values for Status Tag table in 
the Appendix. 

ToEMail Text 150 E-mail address for recipient–for logging 
only. Either ToEmail or ToSMS is required 
when HoldForPickup is TRUE. 

ToSMS Text 50 A phone number for the recipient that the 
USPS can send SMS messages to. Either 
ToEmail or ToSMS is required when 
HoldForPickup is TRUE. 

ToPhone Text 50 Phone number for recipient (required 
when mailing to a P.O. Box and sending 
through First-Class Mail International, 
Priority Mail International, and Express 
Mail International) 
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RubberStampN Text 50 Replaces text in the rubber stamp on the 
layout associated with database field “N” 
(set up in the rubber stamp options). “N” 
can be any value from 1 to 100. 
The Mac client supports up to two Rubber 

Stamps. 

ReturnAddress 
[Mac Only] 

Text  Entire return address as a string with line 
breaks. 

ReturnAddressPhone 
[Mac Only] 

Text  Telephone associated for a ReturnAddress 
(used for Customs form) 

ReturnAddressNickname 
[Mac Only] 

Text  The nickname of an address in the “From” 
Pop-up. Specifiing the nickname allows 
omitting the entire ReturnAddress in each 
request. 

ReturnAddress1 Text 150 First return address line  

ReturnAddress2 Text 150 Second return address line  

ReturnAddress3 Text 150 Third return address line  

ReturnAddress4 Text 150 Fourth return address line  

ReturnAddress5 Text 150 Fifth return address line  

ReturnAddress6 Text 150 Sixth return address line  

Status Text Success or Failure Indicates if the printing succeeded or 
failed. Output only.  
Success–no errors 
Rejected (x)–error occurred 
Refer to the Values for Status Tag table in 
the Appendix for possible error code 
values. 

PIC Text USPS tracking number Tracking number (Delivery Confirmation, 
Signature Confirmation, CONFIRM or 
Express Mail) supplied by the USPS. 
Output only. 

CustomsNumber Text USPS Customs number USPS assigned Customs number for 
Customs Forms Declaration. Output only. 

FinalPostage Currency 99,999.99 Actual postage for transaction. Output 
only. 

TransactionID Numeric  Unique ID for transaction–corresponds to 
the piece count for the account used. 
Output only. 

TransactionDateTime Date YYYYMMDDHHMMSS Date and time the transaction was 
created. Output only. 

PostmarkDate Date YYYYMMDD Indicates the postmark date. Output only. 

 

Syntax Sample of a Printing and XML File  

The following listing shows a syntax sample of a printing XML file.  

 

Note: These examples will work on either DAZzle or Endicia for Mac, but for Endicia for Mac 

the OutputFile option must be set to a Mac-friendly path name, such as 

―~/Documents/sample.xml‖. 
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Listing 1—Sample Printing XML 

<DAZzle Layout="c:\Program Files\Envelope Manager\DAZzle\Zebra.lyt" 

OutputFile='C:\DAZZLE sample.XML' Start='PRINTING' Test='NO' Prompt='YES' 

AutoClose='NO'> 

 <Package ID='1'> 

  <MailClass>PRIORITY</MailClass> 

  <DateAdvance>4</DateAdvance> 

  <PackageType>FLATRATEENVELOPE</PackageType> 

  <OversizeRate>FALSE</OversizeRate> 

  <WeightOz>5</WeightOz> 

  <Width>5</Width> 

  <Length>12.0</Length> 

  <Depth>5.5</Depth> 

  <Services CertifiedMail="OFF" DeliveryConfirmation="ON" 

></Services> 

  <Value>27.00</Value> 

  <Description>t-shirts</Description> 

  <ReferenceID>0038005</ReferenceID> 

  <ToName>Mrs. Sample Name</ToName> 

  <ToAddress1>247 high st</ToAddress1> 

  <ToCity>Palo Alto</ToCity> 

  <ToState>CA</ToState> 

  <ToPostalCode>94031</ToPostalCode> 

  <ToEMail>SampleName@notreal.org</ToEMail> 

 </Package> 

</DAZzle> 

 

Listing 2—Sample XML for International Mail 

<DAZzle Start="PRINTING" Prompt="YES" AutoClose="NO" Test="NO" 

OutputFile="C:\singleintlout.xml" AutoPrintCustomsForms="YES"> 

 <Package ID="1"> 

  <MailClass>INTLFIRST</MailClass> 

  <PackageType>RECTPARCEL</PackageType> 

  <DateAdvance>0</DateAdvance> 

  <WeightOz>40</WeightOz> 

  <Services 

   RegisteredMail = 'OFF' 

   InsuredMail = 'ON' 

   CertifiedMail = 'OFF' 

   RestrictedDelivery = 'OFF' 

   CertificateOfMailing = 'OFF' 

   ReturnReceipt = 'OFF' 

   DeliveryConfirmation = 'OFF' 

   SignatureConfirmation = 'OFF' 

   COD = 'OFF' > 

  </Services> 

  <Value>24.45</Value> 

  <Description>Men’s cotton shirt</Description> 

  <CustomsFormType>CN22</CustomsFormType> 

  <CustomsQuantity1>1</CustomsQuantity1> 

  <CustomsWeight1>40</CustomsWeight1> 

  <CustomsDescription1>Men’s Cotton Shirt</CustomsDescription1> 

  <CustomsValue1>24.45</CustomsValue1> 
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  <CustomsCountry1>Italy</CustomsCountry1> 

  <CustomsCertify>TRUE</CustomsCertify> 

  <CustomsSigner>Joe Customer</CustomsSigner> 

  <ToName>Joe Bloe</ToName> 

  <ToCompany></ToCompany> 

  <ToAddress1>1900 Queen Mary Ave</ToAddress1> 

  <ToAddress2></ToAddress2> 

  <ToCity>Brampton</ToCity> 

  <ToState>ON</ToState> 

  <ToPostalCode>L7A 1Y3</ToPostalCode> 

  <ToCountry>CANADA</ToCountry> 

  <ToEMail>jobloe@phoneyyahoo.com</ToEMail> 

  <RubberStamp1>Item Description</RubberStamp1> 

  <RubberStamp2>381099999</RubberStamp2> 

 </Package> 

</DAZzle> 

 

Listing 3—Sample Multiple Item XML File 

<DAZzle Start='PRINTING' Prompt='YES' AutoClose='NO' 

OutputFile='c:\testout.xml' Test='YES'> 

<Package ID="1"> 

        <MailClass>FIRST</MailClass> 

        <PackageType>ENVELOPE</PackageType> 

        <DateAdvance>0</DateAdvance> 

        <WeightOz>5</WeightOz> 

        <Services InsuredMail="ON" DeliveryConfirmation="OFF" 

COD="OFF"></Services> 

        <CostCenter>25</CostCenter> 

        <Value>25.00</Value> 

        <Description>test 1</Description> 

        <ReferenceID>10</ReferenceID> 

        <ToName>Mark Thomas</ToName> 

        <ToCompany>PSI</ToCompany> 

        <ToAddress1>247 High St</ToAddress1> 

        <ToCity>Palo Alto</ToCity> 

        <ToState>CA</ToState> 

        <ToPostalCode>94301</ToPostalCode> 

        <ToEMail>mt@yahoo.com</ToEMail> 

        <ToPhone>650 321-2640</ToPhone> 

</Package> 

<Package ID="2"> 

        <MailClass>PRIORITY</MailClass> 

        <PackageType>RECTPARCEL</PackageType> 

        <DateAdvance>0</DateAdvance> 

        <WeightOz>16</WeightOz> 

        <Services DeliveryConfirmation="ON" COD="OFF"></Services> 

        <CostCenter>35</CostCenter> 

        <Value>35.00</Value> 

        <Description>test 2</Description> 

        <ReferenceID>20</ReferenceID> 

        <ToName>Jessie Montgomery</ToName> 

        <ToCompany></ToCompany> 

        <ToAddress1>110 Main St</ToAddress1> 

        <ToCity>Los Altos</ToCity> 

        <ToState>CA</ToState> 

        <ToPostalCode>94024</ToPostalCode> 
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</Package> 

<Package ID="3"> 

        <MailClass>PRIORITY</MailClass> 

        <PackageType>FLATRATEBOX</PackageType> 

        <DateAdvance>0</DateAdvance> 

        <WeightOz>16</WeightOz> 

        <Services SignatureConfirmation="ON"></Services> 

        <CostCenter>45</CostCenter> 

        <Value>45.00</Value> 

        <Description>test 3</Description> 

        <ReferenceID>30</ReferenceID> 

        <ToName>Susan Williams</ToName> 

        <ToCompany></ToCompany> 

        <ToAddress1>818 Carmel Ave</ToAddress1> 

        <ToCity>Los Altos</ToCity> 

        <ToState>CA</ToState> 

        <ToPostalCode>94022</ToPostalCode> 

</Package> 

</DAZzle> 

 

Output Information 

DAZzle and Endicia for Mac return printing information in XML format when printing from an XML file 

source (that is, it does NOT create output when printing from the Clipboard). The output data are in the 

same XML format as was supplied. If the application had updated a data element, the output file contains 

the updated element (for example, address data had changed during the verification process). If the data 

element is NOT in the original source data, the application will add the information to the output XML. 

For information about each tag that is updated or added, see the Endicia Client XML Printing Syntax 

section. 

 

The location of the output data varies depending on the source (input). 

 

 For an external file, when printing from a file, DAZzle prompts the user for the name of an output 

file to store the results. The default name is the source file name with ―output‖ appended (for 

example filename-output.xml). When using automated printing with the Prompt element set to 

no, the default file name is automatically used (any existing file with this name will be 

overwritten). 

 For the Clipboard, DAZzle does not return any information to the Clipboard when using XML. If 

return information is desired, use a file-based approach. [Windows Only] 
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4. ADDRESS VERIFICATION [WINDOWS ONLY] 

Verifying a list of addresses can be accomplished with an appropriately formatted XML file. 

 

DAZzle Address Verification XML Syntax 

The DAZzle XML address verification syntax is actually the same as the syntax for Printing, except many 

tags are not required (or otherwise ignored). The minimum set of data is listed in detail in the following 

table.  

Note: Address Verification through XML cannot be fully automated; it will always have user 

prompts and cannot be started using directory monitoring. 

 

The following applies to all elements in the following table: 

 Italic items are optional.  

 Bold items are exported (or added if missing). 

Table 3—XML Verification Elements 

Element Type Size or Values Description 
DAZzle Root - The root node for the XML request. 

 Package Node - Package information. 

 ID Numeric 1-n Numeric identifier for each address in the 
request. There may be multiple address 
(indicium) requests. 

ToName Text 150 Destination Name.  

ToTitle Text 150 Title (follows name line). 

ToCompany Text 150 Company name.  

ToAddress1 Text 150 First address line.  

ToAddress2 Text 150 Second address line.  

ToAddress3 Text 150 Third address line.  

ToAddress4 Text 150 Fourth address line.  

ToAddress5 Text 150 Fifth address line.  

ToAddress6 Text 150 Sixth address line.  

ToCity Text 50 Destination City.  

ToState Text 25 Destination State or Province.  

ToPostalCode Text 15 Destination Postal Code. The format is 
either ZIP5 only or ZIP+4 for US addresses. 

ToZIP4 Text 5 +4 add-on for US addresses. 

ToCountry Text 50 Destination Country. 

ToDeliveryPoint Text 3 Delivery point digits for destination address. 

ToCarrierRoute Text 5 Carrier route for destination address. 

ToReturnCode Text 3 CASS return code for address validation 
Refer to the Values for Status Tag table in 

the Appendix. 

 

Syntax Sample for an Address Verification XML File for DAZzle 

The following listing gives a syntax sample for an address verification XML file for DAZzle.  

Listing 4— Address Verification XML 
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<DAZzle> 

 <Package ID="x"> 

  <ToName></ToName> 

  <ToTitle></ToTitle> 

  <ToCompany></ToCompany> 

  <ToAddress1></ToAddress1> 

  <ToAddress2></ToAddress2> 

  <ToAddress3></ToAddress3> 

  <ToAddress4></ToAddress4> 

  <ToAddress5></ToAddress5> 

  <ToAddress6></ToAddress6> 

  <ToCity></ToCity> 

  <ToState></ToState> 

  <ToPostalCode></ToPostalCode> 

  <ToZIP4></ToZIP4> 

  <ToCountry></ToCountry> 

  <ToDeliveryPoint></ToDeliveryPoint> 

  <ToCarrierRoute></ToCarrierRoute> 

  <ToReturnCode></ToReturnCode> 

 </Package> 

</DAZzle> 

Output Information 

DAZzle updates the source data with the results of the address verification process. The output data is in 

the same XML format as was supplied. If DAZzle updated a data element, the output file will contain the 

updated element. If the data element is NOT in the original source data, DAZzle will add the information 

to the XML data. Refer to the Address Verification XML listing for details on each tag that is updated or 

added.  

 

Note: The verification process truly updates the source data. This is different than printing with 

XML that only includes printed items in the output result set. If an address fails verification, it is 

still updated with the return code that indicates why the verification failed. 
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5. ADDRESS BOOK [WINDOWS ONLY] 

Data may be imported into or exported from the DAZzle Address Book through XML-formatted text 

files. 

Import XML Data  

To import XML data into the DAZzle Address Book, select File > Import from the Address Book tab. 

Then, change the file type to ―Text, XML Format‖ and select the XML file. If the file is a properly 

formatted XML file, all of the data items will be immediately imported (added) to the DAZzle Address 

Book. 

Export XML Data 

To export DAZzle Address Book information to an XML-formatted file, select File > Export from the 

menu. Change the file type to ―Text, XML format‖ and select a file name with an XML extension. 

DAZzle then exports all selected addresses to that file in XML format. 

The following applies to all elements in the following table: 

 

 Italic items are optional.  

 Bold items are exported (or added if missing). 

 

Table 4—XML Verification Elements 

Element Type Size or Values Description 
DAZzle Root - The root node for the XML request. 

 Package Node - Package information. 

 ID numeric 1-n Numeric identifier for each address in the 
request. There may be multiple addresses. 

ToSalutation Text 50 Salutation (for example Mr., Mrs., Dr., etc.), 
export only 

ToFirstName Text 50 First name, export only 

ToMiddleName Text 50 Middle name, export only 

ToLastName Text 50 Last name, export only 

ToName Text 150 Name  

ToTitle Text 150 Title (follows name line) 

ToCompany Text 150 Company name  

ToAddress1 Text 150 First address line  

ToAddress2 Text 150 Second address line  

ToAddress3 Text 150 Third address line  

ToAddress4 Text 150 Fourth address line  

ToAddress5 Text 150 Fifth address line  

ToAddress6 Text 150 Sixth address line  

ToCity Text 50 City  

ToState Text 25 State or province  

ToPostalCode Text 15 Postal code. The format is either ZIP5 only 
or ZIP+4 for US addresses. 

ToZIP4 Text 5 +4 add-on for US addresses 

ToCountry Text 50 Country 

ToDeliveryPoint Text 3 Delivery point digits for address 

ToCarrierRoute Text 5 Carrier route for address 
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Element Type Size or Values Description 
ToReturnCode Text 3 CASS return code for address validation 

Refer to the Values for Status Tag table in 
the Appendix. 

ToCASSDate Date YYYYMMDD Date of CASS verification 

ToEmail Text 100 E-mail address 

ToPhone Text 20 Phone number for recipient (required when 
mailing to a P.O. Box and sending through 
First-Class Mail International, Priority Mail 
International, and Express Mail 
International) 

 

Listing 5—Address Book XML 

<DAZzle> 

 <Package ID="x"> 

  <ToName></ToName> 

  <ToTitle></ToTitle> 

  <ToCompany></ToCompany> 

  <ToAddress1></ToAddress1> 

  <ToAddress2></ToAddress2> 

  <ToAddress3></ToAddress3> 

  <ToAddress4></ToAddress4> 

  <ToAddress5></ToAddress5> 

  <ToAddress6></ToAddress6> 

  <ToCity></ToCity> 

  <ToState></ToState> 

  <ToPostalCode></ToPostalCode> 

  <ToZIP4></ToZIP4> 

  <ToCountry></ToCountry> 

  <ToDeliveryPoint></ToDeliveryPoint> 

  <ToCarrierRoute></ToCarrierRoute> 

  <ToReturnCode></ToReturnCode> 

  <ToEMail></ToEMail> 

  <ToPhone></ToPhone> 

 </Package> 

</DAZzle> 
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6. POSTAGE LOG 

Data may be exported from the DAZzle Postage Log (referred to as the Mailing Log in Endicia for Mac) 

through XML-formatted text files. 

Export Data from the Postage Log  

To export DAZzle postage log information to an XML-formatted file, click the Backup/Export button on 

the Postage Log window. On the Backup options window, select Export and then click OK. Select the file 

type of Text, XML Format and enter the XML file name, and DAZzle will then export all postage log 

records to that file in XML format. 

Table 5—XML Log Elements 

Element Type Size or Values Description 
DAZzleLog Root - The root node for the XML 

 Record Node - Record information  

 ID Numeric 
attribute 

1-n Numeric identifier for each record. 
Sequential entry in the log file.  

Account Text 6 Six-digit customer account number 

DeviceID Text 10 Corresponds to the device ID printed with 
each postage indicia. 

AccountName Text 60 Sender’s name 

TransactionID Numeric  Unique ID for transaction–corresponds to 
the piece count for the account used. 

Status Text Success or Failure Success means transaction completed 
successfully. 

TransactionType Numeric 2 07 is postage purchase.  
08 is a “stamp”. 

TransactionDateTime Date YYYYMMDDHHMMSS Date and time the transaction was created. 

PostmarkDateTime Date MM/DD/YYYY Postmark date printed with indicia 

AccountBalance Currency 10 Funds remaining in account after 
transaction 

MailClass text None 
First Class 
First Class, Postcard 
Priority Mail 
(and so on) 

Mail class used for the item. 

WeightOz Numeric 6 Weight of the package in ounces 

Services Node - Special Services requested for the package. 

 RegisteredMail Attribute ON 
 
OFF 

Registered Mail requested 
 
Registered Mail not requested 

InsuredMail  Attribute ON 
 
OFF 

Insurance requested 
 
Insurance not requested 

CertifiedMail Attribute ON 
 
OFF 

Certified Mail requested 
 
Certified Mail not requested 

 RestrictedDelivery Attribute ON 
 
OFF 

Restricted Delivery requested 
 
Restricted Delivery not requested 
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CertificateOfMailing Attribute ON 
 
OFF 

Certificate Of Mailing requested 
 
Certificate Of Mailing not requested 

ReturnReceipt Attribute ON 
 
OFF 

Return Receipt requested 
 
Return Receipt not requested 

DeliveryConfirmation  Attribute ON 
 
OFF 

Delivery Confirmation® requested 
 
Delivery Confirmation not requested 

SignatureConfirmatio
n  

Attribute ON 
 
OFF 

Signature Confirmation® requested 
 
Signature Confirmation not requested 

COD Attribute ON 
 
OFF 

COD requested 
 
COD not requested 

CostCenter Numeric 8 Optional cost center code for accounting 
purposes–this is listed as Group Code in the 
DAZzle Print window. 

Value Currency 99,999.99 Value of the item shipped. Used for 
insurance and other optional services (to 
the cent). 

Description Text 50 Description of the item shipped. Used for 
authentication by recipient. 

ReferenceID Text 25 A reference value for logs 

ToAddress Text 150 First address line  

ToPostalCode Text 15 Destination Postal Code. The format is 
either ZIP5 only or ZIP+4 for US addresses. 

ToEMail Text 150 E-mail address for recipient–for logging only 

ToPhone Text 50  Phone number for recipient (required when 
mailing to a P.O. Box and sending through 
First-Class Mail International, Priority Mail 
International, and Express Mail 
International) 

PIC Text USPS tracking number Tracking number (Delivery Confirmation, 
Signature Confirmation, or Express Mail) 
supplied by the USPS 

CustomsID Text 15 Customs ID associated with international 
mail items 

InsuranceType Text UPIC 
ENDICIA 
USPS 
NONE 

Type of insurance used 

ExpressMailOptions Text  Coded field for Express Mail options 
selected 
 

ReplyPostage Text YES 
NO 

Was Reply Postage used? 

Reprinted Text YES 
NO 

Was the item reprinted? 

RefundStatus Text YES 
NO 

Was e-refund selected for this item? 
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DeliveryStatus Text  Coded field indicating the delivery status of 
the item (if some form of tracking was 
used). 

DeliveryDescription Text 50 Delivery status description from the USPS 

CustomsContentType Numeric 0=Sample 
1=Gift 
2=Documents 
3=Other 
4=None 
5=Returned goods 

Content Type selected on customs forms (if 
applicable) 

CustomsFormType Numeric 0=None 
2=2976A (CN22) 
3=2976 (CP72) 

Customs form used (if applicable) 
 

CustomsDescriptionX Text 25 Description for line X of customs form 

CustomsQuantityX Numeric 10 Quantity for line X of customs form 

CustomsWeightX Numeric 10 Weight (ounces) for line X of customs form 

CustomsValueX Currency 10 Value for line X of customs form 

CustomsCountryX Text 25 Origin Country for line X of customs form 

FinalPostage Currency 99,999.99 Actual postage for transaction 

 

Listing 6—Postage Log XML 

<DAZzleLog Account='601225' Name='Joe Customer’ Phone='(650) 555-2640' 

Email='joe@companyname.com'> 

<Record ID="6990"> 

<Account>601225</Account> 

<DeviceID>071V00601225</DeviceID> 

<AccountName> Joe Customer </AccountName> 

<TransactionID>12289</TransactionID> 

<TransactionDateTime>09/06/2006 10:24 AM</TransactionDateTime> 

<Status>Success</Status> 

<TransactionType>08</TransactionType> 

<AccountBalance>40,627.302</AccountBalance> 

<PostmarkDateTime>09/06/2006</PostmarkDateTime> 

<ToAddress>DAVID Recipient, 15021 NE 31st St, Vancouver, WA 98682-

8302</ToAddress> 

<ToPostalCode>98682830221</ToPostalCode> 

<FinalPostage>1.73</FinalPostage> 

<MailClass>Package, Media Mail</MailClass> 

<Services DeliveryConfirmation = 'ON'></Services> 

<WeightOz>16</WeightOz> 

<PIC>9102148008600000012345</PIC> 

<Description>AOB 290014164666-370802792</Description> 

<Value>0.00</Value> 

<CostCenter>0</CostCenter> 

<Insurance>NONE</Insurance> 

<ReplyPostage>NO</ReplyPostage> 

<Reprinted>NO</Reprinted> 

<CustomsContentType>4</CustomsContentType> 

</Record> 

<Record ID="7002"> 

<Account>601225</Account> 

<DeviceID>071V00601225</DeviceID> 

<AccountName> Joe Customer </AccountName> 

<TransactionID>12301</TransactionID> 
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<TransactionDateTime>09/07/2006  4:52 PM</TransactionDateTime> 

<Status>Success</Status> 

<TransactionType>08</TransactionType> 

<AccountBalance>40,586.192</AccountBalance> 

<PostmarkDateTime>09/07/2006</PostmarkDateTime> 

<ToAddress>Fernando Imagine, 17 Calle Bonaparte Apt 1, Caguas, PR 00725-

7101</ToAddress> 

<ToPostalCode>00725710101</ToPostalCode> 

<FinalPostage>18.80</FinalPostage> 

<MailClass>Express Mail</MailClass> 

<Services></Services> 

<WeightOz>16</WeightOz> 

<PIC>EO010000203US</PIC> 

<Value>0.00</Value> 

<CostCenter>0</CostCenter> 

<Insurance>NONE</Insurance> 

<ExpressMailOptions>NYY</ExpressMailOptions> 

<ReplyPostage>NO</ReplyPostage> 

<Reprinted>NO</Reprinted> 

<CustomsContentType>4</CustomsContentType> 

</Record> 

</DAZzleLog> 
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7. VISTA AND WINDOWS 7 COMPATIBLE INSTALLATION AND 

UPDATES 

The main sections of this chapter discuss: 

 Vista and Windows 7 Compatible New Installations for DAZzle 

 Vista and Windows 7 Compatible Updates for Existing Installations of DAZzle 

Vista and Windows 7 Compatible New Installations for DAZzle 

When performing a new or ―fresh‖ installation of the Vista and Windows 7 compatible version of 

DAZzle, a dialog box prompts the user to choose between installing DAZzle in Shared mode or Private 

mode. The default value is Shared. 

 

Under Shared mode: 

 All data files are installed to the %COMMON_DOCUMENT%\Endicia\DAZzle folder, for 

example, C:\Users\Public\Documents\Endicia\DAZzle.  

 

Under the Private mode: 

 Application data files are installed to the user’s %APPLICATION_DATA%\Endicia\DAZzle 

folder, for example, C:\Users\<user name>\AppData\Roaming\Endicia\DAZzle.  

 All user data files are installed to the user’s %PERSONAL_DOCUMENTS%\Endicia\DAZzle 

folder, for example, C:\Users\<user name>\Documents\Endicia\DAZzle.  

 

The following registry settings are automatically generated the first time DAZzle is launched: 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\VistaCompliant  

(The string value ―YES‖ or ―NO‖ depends on whether any user has done the Vista or Windows 7 

transition for the machine.) 

 HKEY_CURRENT_USER\Software\Envelope Manager\dazzle\Preferences\VistaCompliant  

(The string value ―YES‖ or ―NO‖ depends on whether the current transition has been done for the 

current Windows login user.) 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\ShareMode  

(The string value ―Private‖ or ―Shared‖ depends on which mode the user selected during the 

Vista or Windows 7 transition.) 

 

Under Private mode: 

 HKEY_CURRENT_USER\Software\Envelope Manager\dazzle\Preferences\AppDataDirectory 

(This is the string value of the application data path after Vista or Windows 7 transition under 

Private mode.) 

 HKEY_CURRENT_USER\Software\Envelope Manager\dazzle\Preferences\UserDataDirectory 

(This is the string value of the user data path after Vista or Windows 7 transition under Private 

mode.) 

 

Under Shared mode: 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\AppDataDirectory  

(This is the string value of the app data path after Vista or Windows 7 transition under Shared 

mode.) 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\UserDataDirectory  

(This is the string value of the user data path after Vista and Windows 7 transition under Shared 

mode.) 
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Vista and Windows 7 Compatible Updates for Existing Installations of 
DAZzle 

After upgrading from an existing installation of DAZzle to the Vista and Windows 7 compatible version 

of DAZzle, the user has the option of converting DAZzle to be Vista and Windows 7 compatible. Before 

the transition starts, a dialog box prompts the user to choose between installing DAZzle in Shared mode 

or Private mode. The default value is Shared. 

 

Under Shared mode: 

 All data files are moved to the %COMMON_DOCUMENT%\Endicia\DAZzle folder, for 

example, C:\Users\Public\Documents\Endicia\DAZzle.  

 

Under the Private mode: 

 Application data files are copied to the user’s %APPLICATION_DATA%\Endicia\DAZzle folder, 

for example, C:\Users\<user name>\AppData\Roaming\Endicia\DAZzle.  

 All user data files are copied to the user’s %PERSONAL_DOCUMENTS%\Endicia\DAZzle 

folder, for example, C:\Users\<user name>\Documents\Endicia\DAZzle. 

 

Note the following: 

 In Vista and Windows 7, the transition can be done only when DAZzle was launched by selecting 

―Run As Administrator‖. 

 When another Windows user launches DAZzle for the first time after the Vista and Windows 7 

Compatible transition, the user will see a message about the transition, and a set of data files will 

be copied to his or her own app and user data folders. 

 If any files already exist in the destination folder with same names as the original folder, a 

message will be displayed.  

 After the transition, a file named ―FileMoveLog.txt‖ will be created in the destination data folder. 

This file shows the original and destination locations of the moved files. 

 Application data files and user data files are moved to different locations. The location of each 

can be found in Registry settings after the transition: ―AppDataDirectory‖ and 

―UserDataDirectory‖.  

 If a file fails to move, the transition will roll back all the files, and a message will indicate what 

has happened.  

 All registry settings related to file location are changed during the transition according to the 

mode selected. In this way, the next time that DAZzle is launched, users will not get a ―File can’t 

be found‖ message. 

 The folder ―\xml\‖ under DAZzle installation directory will be moved to the user data folder.  

 

The following registry settings will be automatically generated the first time DAZzle is launched: 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\VistaCompliant  

(The string value ―YES‖ or ―NO‖ depends on whether any user has done the Vista or Windows 7 

transition for the machine.) 

 HKEY_CURRENT_USER\Software\Envelope Manager\dazzle\Preference\VistaCompliant  

(The string value ―YES‖ or ―NO‖ depends on whether the current transition has been done for the 

current Windows login user.) 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\ShareMode  

(The string value ―Private‖ or ―Shared‖ depends on which mode user selected during the Vista or  

Windows 7 transition. ) 

 

Under Private mode: 
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 HKEY_CURRENT_USER\Software\Envelope Manager\dazzle\Preference\AppDataDirectory 

(This is the string value of the application data path after Vista or  Windows 7 transition under 

Private mode.) 

 HKEY_CURRENT_USER\Software\Envelope Manager\dazzle\Preference\UserDataDirectory 

(This is the string value of the user data path after Vista or  Windows 7 transition under Private 

mode.) 

 

Under Shared mode: 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\AppDataDirectory  

(This is the string value of the app data path after Vista or  Windows 7 transition under Shared 

mode.) 

 HKEY_LOCAL_MACHINE\Software\Envelope Manager\DAZzle\UserDataDirectory  

(This is the string value of the user data path after Vista or  Windows 7 transition under Shared 

mode.) 
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Appendix A. Address Verification Return Code Values 

The following table shows the address verification return code values. 

Table 6—Address Verification Return Code Values 

Value Description 
10 Invalid address 

11 Invalid Zip Code 

12 Invalid state code 

13 Invalid city 

21 Address not found 

22 Multiple matches, too ambiguous 

25 City, State, and ZIP Code are valid, but street address is not a match. 

31 Exact match 

32 Default match, more information may give a more specific +4 

 



 

CONFIDENTIAL  Endicia, A Newell Rubbermaid Company  Page 39 

Appendix B. Values for Status Tags 

The following table shows the values for status tags. 

Table 7—Values for Status Tags 

Value Description 
0 Success--no errors during processing 

-3 Address Verification failed (return code less than 25) 

-4 Unsupported mail class for international mail or invalid weight/rate values 

-5 Unsupported domestic mail options (Windows only) 

-6 USPS Delivery Confirmation error – denied, service unavailable or communication error 

-7 USPS Express Mail error – denied, service unavailable or communication error 

-8 USPS Customs Forms error – denied, service unavailable or communication error 

-9 International Mail Shipping Label (large or small) processing error 

-10 CONFIRM service error – denied, service unavailable or communication error 

-11 Express Mail International, Priority Mail International, or First-Class Mail International Error–no “to 
phone” for mail addressed to P. O. Boxes. 

-12 Invalid feature for account. 
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Appendix C. Change History 

Version 11.0 

The following changes have been made to the Endicia XML interface: 

 

 Additional Values  

 New Tags or Options 

 

Additional Values 
 

The following table shows the additional value for MailClass element of the XML Printing Elements 

table: 

MailClass Text CRITICALMAIL Critical Mail—Only available to qualified 
Commercial Plus customers. PackageType 
has to be ENVELOPE or FLAT. 

 

 

The following table shows additional values for PackageType element of the XML Printing Elements 

table: 

 

PackageType Text FLATRATELEGALENVELOPE 
 
 
REGIONALRATEBOXA 
 
 
REGIONALRATEBOXB 
 
 
FLATRATEGIFTCARDNVELOP
E 
 
FLATRATEWINDOWENVELO
PE 
 
FLATRATECARDBOARDENVE
LOPE 
 
SMALLFLATRATEENVELOPE 
 

Flat Rate Legal Envelope—Priority Mail and 
Express Mail (Domestic only) 
 
Regional Rate Box A—Priority Mail 
(Domestic only) 
 
Regional Rate Box B—Priority Mail 
(Domestic only) 
 
Flat Rate Giftcard Envelope – Priority Mail 
and Express Mail (Domestic only) 
 
Flat Rate Window Envelope – Priority Mail 
and Express Mail (Domestic only) 
 
Flat Rate Cardboard Envelope – Priority Mail 
and Express Mail (Domestic only) 
 
Small Flat Rate Envelope – Priority Mail and 
Express Mail (Domestic only) 
 

 

Changed Descriptions 
 

The following table shows changed descriptions for PackageType element of the XML Printing Elements 

table: 

 

PackageType Text FLATRATEPADDEDENVELOP
E 
 

Flat Rate Padded Envelope–Priority Mail  
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New Tags or Options 
 

The following table shows new tags or options in the Services element of the XML Printing Elements 

table: 

 

HoldForPickup Text TRUE 
FALSE 

For Express Mail, Priority Mail, First Class 
Mail, Parcel Select, use TRUE to indicate Hold 
For Pickup requested. 

HFPFacilityID Text 20 Facility ID of the Post Office that will hold the 
item for pickup. 

HFPFacilityName Text 150 Facility name of the Post Office that will hold 
the item for pickup. 

HFPFacilityAddress Text 150 Facility address of the Post Office that will 
hold the item for pickup. 

HFPFacilityCity Text 50 City of the Post Office that will hold the item 
for pickup. 

HFPFacilityState Text 25 State of the Post Office that will hold the item 
for pickup. 

HFPFacilityZip5 Text 5 5 digit ZIP Code of the Post Office that will 
hold the item for pickup. 

HFPFacilityZip4 Text 4 +4 add-on ZIP Code of the Post Office that will 
hold the item for pickup. 

 

Version 10.3 

The following changes have been made to the Endicia XML interface with version 10.1: 

 

 Additional value for status tags. 

 

Additional Value for Status Tags 
The following table shows an additional value for the status tags: 

 

Value Description 

-12 Invalid feature for account. 

 

Version 10.1 

The following changes have been made to the Endicia XML interface with version 10.1: 

 

 New Tags or Options 

 

New Tags or Options 
The following table shows new tags or options in the XML Printing Elements table in version 10.1. 

New Tags or Options in Version 10.1 

Tag Type Size or 
Value 

Description 

CustomsQuantityN Numeric 8 Optional: “N” can be any integer from 1 through 30. 
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Tag Type Size or 
Value 

Description 

Quantity of the “Nth” item in customs declaration.  
For Windows only. 

CustomsDescriptionN Text 50 Optional: Description of the “Nth” item in the customs 
declaration.  
For Windows only. 

CustomsWeightN Numeric 8 Optional: Weight of the “Nth” item in customs 
declaration–in ounces. 

CustomsValueN Currency 99,999.99 Optional: Value of the “Nth” item in the customs 
declaration.  
For Windows only. 

CustomsCountryN Text 25 Optional: Country of Origin for the “Nth” item in the 
customs declaration. This MUST be a valid, USPS 
recognized country.  
For Windows only. 

CustomsHTSN Numeric 10 Optional: “N” can be any integer from 1 through 30. 
Harmonized Tariff Schedule (HTS) ID for the “Nth” item 
in customs declaration.  
For Windows only. 

 

Documentation Correction 
On May 24, 2010, corrected a typographical error—a missing space: 

Was:  
<ServicesCertifiedMail="OFF" DeliveryConfirmation="ON" ></Services>  

Corrected to: 
<Services CertifiedMail="OFF" DeliveryConfirmation="ON" ></Services>  

 

Version 10.0 

With the January 2010 US Postal Service price change or enhancements, the following fully backward 

compatible changes have been made to the XML interface with version 10.0:  

 

 New Tags or Options 

 

New Tags or Options 
The following table shows new tags or options in version 10.0. 

New Tags or Options in Version 10.0 

Tag  Value Description 

PackageType FLATRATEPADDEDENVELOPE Flat Rate Padded Envelope–
Qualified Commercial Plus 
Pricing Priority Mail (Domestic 
only) 

MailClass PARCELSELECT Parcel Select®. Delivery 
Confirmation or Signature 
Confirmation is required. 

Status -5 Unsupported domestic mail 
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Tag  Value Description 

options (Windows only) 
 

Version 9.1 

This document includes a new chapter, Vista and Windows 7 Compatible Installation and Updates, the 

registry entries that make DAZzle data compatible with Microsoft Vista and Windows 7. 

 

This new chapter is organized by new or ―fresh‖ installations of DAZzle and upgrades from previous 

installations of DAZzle. 

Version 9.0 

With the January 2009 US Postal Service price change or enhancements, the following fully backward 

compatible changes have been made to the XML interface with version 9.0:  

 

• New Tags or Options 

 

New Tags or Options 
The following table shows new tags or options in version 9.0. 

New Tags or Options in Version 9.0 

Tag  Value Description 

PackageType FLATRATESMALLBOX Flat Rate Small Box–Priority Mail 
(Domestic and International) 

Status -11 Express Mail International®, 
Priority Mail International®, or 
First-Class Mail International® 
Error–no “to phone” for mail 
addressed to P. O. Boxes. 

 

Version 8.1.06 

There are no changes to XML interface for the 8.1.06 release, however, effective September 12, 2008, the 

USPS requires a permit to print postage for Bound Printed Matter (BPM). As a result, you must update 

any DAZzle configurations that use BPM.  

Version 8.1 

There are no XML interface element changes with release 8.1 of DAZzle. However, the USPS has 

changed some of the mailing rules that may require the additional use of existing tags. First-Class Mail 

International is ―shape based‖ starting May 12, 2008, so the shape or dimension information for each 

FCMI package should be supplied in the XML (the same as domestic First-Class Mail). 

Version 8.0 

With the March 2008 US Postal Service rate enhancements, there are some minor changes to the DAZzle 

XML interface with version 8.0.  

The following (fully backward compatible) changes have been made to the XML interface: 

• New Tags or Options 
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• Output Changes 

New Tags or Options 

The following table shows new tags or options in version 8.0. 

Table 8—New Tags or Options in Version 8.0 

Tag Value Description 
PackageType FLATRATELARGEBOX Large Flat Rate Box–Priority Mail 

(Domestic and International) 

ExpressMailPremiumService TRUE (or YES or ON) 
 
 
 
FALSE (or NO or OFF) 

Enable Premium Service 
(Sunday/Holiday Delivery) for 
Express Mail–ONLY applies when 
Mail Class is Express Mail  
Turn off Premium Service 

 

Output Changes 

With the addition of support for the USPS Confirm® tracking system in DAZzle 8.0, the CONFIRM 

tracking number is output in the ―PIC‖ output tag (where DC and Express Mail tracking numbers are the 

output) when printing with that option enabled.  

Note: Because the use of CONFIRM is configured as part of a layout, there is no option to turn 

CONFIRM on or off through XML. Choose a layout that is preconfigured with CONFIRM enabled. 

Version 7.0 

Due to the May 2007 US Postal Service rate changes, there are significant changes to the DAZzle XML 

interface with version 7.0. A number of new tags were added to support new mail classes, some tags have 

become obsolete and most importantly, for backwards compatibility DAZzle contains new logic to 

automatically convert use of obsolete tags to the new tags. These assumptions may not be correct in all 

cases and conversion to the new tags should be made as soon as possible. While the ―obsolete‖ tags will 

be converted to the new tags by DAZzle, the obsolete tags will be dropped in version 7.1 of DAZzle. 

 

Important! Do NOT use version 7.0 XML with any versions of DAZzle prior to version 7.0! 

Your results will be unpredictable. 

 

The following sections summarize the changes with version 7.0: 

 

• New tags and options 

• Obsolete tags or options 

• Backwards compatibility 

 

New tags and options 

The following table describes new tags and options in version 7.0. 

Table 9—New Tags and Options in Version 7.0 

Tag Value Description 
OversizeRate TRUE  

FALSE 
TRUE means to use the oversized rate for Parcel 
Post. 

NonMachinable TRUE  
FALSE 

TRUE means use non-machinable rates. Applies to 
First-Class Mail, Parcel Post, and First-Class Mail 
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Tag Value Description 
International.  

BalloonRate TRUE  
FALSE 

TRUE means use the “balloon rate” for Priority 
Mail (the 20-lb. rate). Setting the weight to 20 lbs. 
has same effect. 

PackageType POSTCARD  
 
ENVELOPE  
FLAT  
 
RECTPARCEL  
NONRECTPARCEL 
 
FLATRATEENVELOPE 
 
FLATRATEBOX 

Postcard rate (First-Class Mail and First-Class Mail 
International). 
Standard “letter” rate. 
Large Envelope (Flat) rate (only effects rate for 
First-Class Mail or Bound Printed Matter). 
Rectangular Parcel–the standard parcel. 
Non-rectangular parcel–impacts rate for Priority 
Mail. 
Flat Rate Envelope–Priority Mail and Express Mail. 
Flat Rate Box–Priority Mail. 

MailClass INTLFIRST  
 
INTLEXPRESS  
INTLPRIORITY  

First-Class Mail International replaces INTLLETTER 
and INTLAIRLETTER.  
Express Mail International replaces INTLGEM. 
Priority Mail International replaces INTLGPM, 
INTLGPMFRSMALL, and INTLGPMFRLARGE. 

Width Numeric, 0.00 to 130.00 inches Width of envelope, flat, or package. Optional, but 
recommended on Priority Mail and Parcel Post for 
proper compliance with USPS regulations. 

Length Numeric, 0.00 to 130.00 inches Length of envelope, flat, or package. Optional, but 
recommended on Priority Mail and Parcel Post for 
proper compliance with USPS regulations. 

Depth Numeric, 0.00 to 130.00 inches  Depth (or thickness) of envelope, flat, or package. 
Optional, but recommended on Priority Mail and 
Parcel Post for proper compliance with USPS 
regulations. 

ContentsType RETURNEDGOODS New option for ContentsType tag. 

CustomsSigner Text, 50 Name of person certifying that the customs 
information is correct. This name will be printed 
on the customs form in place of a signature IF 
CustomsCertify is TRUE. 

CustomsCertify TRUE FALSE TRUE means that the customs information is 
certified to be correct and the CustomsSigner 
name should be printed. 

 

Obsolete tags or options 

The following table describes obsolete tags and options as of version 7.0. 

Table 10—ObsoleteTags or Options in Version 7.0 

Tag Value Description 
MailClass POSTCARD  

INTLGEM  
INTLGPM 
INTLGPMFRSMALL 
INTLGPMFRLARGE 
INTLLETTER 

First Class Mail–replaced by new PackageType option. 
Global Express Mail–replaced by INTLEXPRESS. 
Global Priority Mail–replaced by INTLPRIORITY. 
Global Priority Mail, Small Flat Rate–obsolete class. 
Global Priority Mail, Large Flat Rate–obsolete class. 
International, Economy Letter–obsolete class. 



 

CONFIDENTIAL  Endicia, A Newell Rubbermaid Company  Page 46 

Tag Value Description 
INTLAIRLETTER 
INTLAEROGRAMME 
INTLPARCEL 
INTLAIRPARCEL 
INTLPOSTCARD 

International, Air Letter–obsolete class. 
International, Aerogramme–obsolete class. 
International, Economy Parcel–obsolete class. 
International, Air Parcel–obsolete class. 
International Postcard–replaced by PackageType option. 

Oversize All Replaced by OversizeRate, NonMachinable, and BalloonRate. 

FlatRate All Replaced by new PackageType tag. 

All obsolete tags and options have been dropped from the full specifications in section 2. 

Backwards compatibility 

 

While some of the changes in version 7.0 are ―universal‖ and apply equally well to the 2006 and 2007 

rates, a number of changes do not directly apply if used with the wrong rates. To compensate for this, 

DAZzle applies the following ―rules‖ to convert the use of tags that do not apply to the ―current‖ rates. 

In general when a new tag has been added that replaces the functionality of an obsolete tag (for example 

BalloonRate and Oversize), and BOTH tags appear in the XML, the functionality of the new tag will 

override any setting of the obsolete tag. For example, if both Oversize and BalloonRate are used, 

BalloonRate will override the values for Oversize. 

When using obsolete tags when the new 2007 postage rates are in effect (basically, if ―old‖ XML is used 

with no changes to the new tags): 

 

 Oversize=YES will result in non-machinable being TRUE if the mail class is First-Class (both 

domestic and international) or Parcel Post. 

 Oversize=YES will result in Balloon Rate being TRUE if the mail class is Priority Mail. 

 Oversize=YES and the weight = 71 lbs will result in the use oversize rate for Parcel Post. 

 FlatRate=YES is the same as PackageType=FLATRATEENVELOPE. 

 FlatRate=BOX is the same as PackageType=FLATRATEBOX. 

 MailClass=POSTCARD is converted to MailClass=FIRST and 

PackageType=POSTCARD. 

 MailClass=INTLAEROGRAMME is converted to MailClass=FIRST and 

PackageType=POSTCARD. (Aerogrammes have been discontinued.) 

 MailClass=INTLGEM is converted to MailClass=INTLEXPRESS. 

 MailClass=INTLGPM is converted to MailClass=INTLPRIORITY. 

 MailClass=INTLGPMFRSMALL is converted to MailClass=INTLPRIORITY and 

PackageType=FLATRATEENVELOPE. 

 MailClass=INTLGPMFRLARGE is converted to MailClass=INTLPRIORITY and 

PackageType=FLATRATEBOX. 

 MailClass=INTLLETTER is converted to MailClass=INTLFIRST and 

PackageType=ENVELOPE. 

 MailClass=INTLAIRLETTER is converted to MailClass=INTLFIRST and 

PackageType=ENVELOPE. 

 MailClass=INTLAIRPARCEL is converted to MailClass=INTLPRIORITY and 

PackageType=RECTPARCEL. 

 MailClass=INTLPARCEL is converted to MailClass=INTLPRIORITY and 

PackageType=RECTPARCEL. 

When using new 7.0 (2007) rate tags while the 2006 postage rates are still in effect (you convert to the 

new XML format before May 14, 2007): 
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 MailClass=INTLFIRST is converted to MailClass=INTLLETTER. 

 MailClass=INTLEXPRESS is converted to MailClass=INTLGEM. 

 MailClass=INTLPRIORITY is converted to MailClass=INTLGPM. 

 MailClass=INTLPRIORITY and PackageType=FLATRATEENVELOPE is converted to 

MailClass=INTLGPMFRSMALL. 

 MailClass=INTLPRIORITY and PackageType=FLATRATEBOX is converted to 

MailClass=INTLGPMFRLARGE. 

 Use of Width, Height, or Depth has no impact (is ignored). 

 Use of RECTPARCEL, NONRECTPARCEL, or FLAT has no impact (are ignored). 

 Use of CustomsSigner or CustomsCertify has no impact (are ignored). 

 

 

 

 

 

 


